Visitor Intercept Display issues in the Western US and Eastern US Regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted May 08, 2026 - 22:42 UTC

Update

We have identified additional impact in the Eastern US region.
Posted May 08, 2026 - 21:13 UTC

Investigating

We are currently investigating an issue with intercept display in Western US region.
Posted May 08, 2026 - 17:56 UTC
This incident affected: Website / App Insights (Visitor Intercept Display).