Intermittent issues with Online Reviews across all regions

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 12:44 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 12, 2025 - 17:52 UTC

Update

We are seeing recovery, however yet to receive the confirmation that issue is fully resolved from the Google's end.
Posted Sep 12, 2025 - 08:32 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 11, 2025 - 21:01 UTC

Monitoring

There are currently delays in Online Review ingestion and review replies across all regions due to upstream issues with Googles APIs.
Posted Sep 11, 2025 - 14:28 UTC
This incident affected: Data Processing.