Connectors Failures for US and EU Customers

Incident Report for Qualtrics

Resolved

New runs are running successfully. Recovery In Progress
Posted Jan 19, 2026 - 20:20 UTC

Monitoring

The issue is resolved now, we are working on Data Recovery
Posted Jan 19, 2026 - 16:37 UTC

Update

We are currently investigating the issue
Posted Jan 19, 2026 - 15:36 UTC

Investigating

The Discover connector is not working and is failing which might be causing delays in data ingestion.
Posted Jan 19, 2026 - 15:02 UTC
This incident affected: Discover Studio (Endpoint: https://cxstudio.clarabridge.net/dashboard/).