Discover Connector Access Issue in Australia Region

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Jun 28, 2025 - 03:24 UTC

Investigating

Access to Discover connectors tab is impacted in ANZ region. We are currently investigating the issue.
Posted Jun 27, 2025 - 20:03 UTC
This incident affected: Discover Studio (ANZ Endpoint: https://studio.aus1.qualtrics.io/dashboard/).