Ticketing issues in Eastern US region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Mar 09, 2026 - 15:47 UTC

Investigating

We are currently investigating an issue with the ticketing tab in the Eastern US region. Users may see latency with accessing existing tickets or ticket functions.
Posted Mar 09, 2026 - 15:06 UTC
This incident affected: Tickets.