Dashboard issues in Eastern US region

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 19:15 UTC

Investigating

We are currently investigating an issue with dashboards loading data in the Eastern US region.
Posted Jan 29, 2026 - 19:00 UTC
This incident affected: Dashboards.