Email distributions issue in multiple regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Jul 15, 2025 - 02:02 UTC

Investigating

We are currently investigating an issue with emails bouncing in the Eastern US, Western US, Canadian and European regions.
Posted Jul 15, 2025 - 01:11 UTC
This incident affected: Distributions (Email).