Dashboard Viewer App issues in the Western US region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Jun 25, 2025 - 22:01 UTC

Investigating

We are currently investigating an issue causing Participant users to be unable to access the dashboard viewer app in the Western US region.
Posted Jun 25, 2025 - 21:27 UTC
This incident affected: Dashboards.