2 Factor Authentication issues in European region

Incident Report for Qualtrics

Resolved

The 2FA issues are now resolved.
Posted Mar 31, 2025 - 10:33 UTC

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 08:06 UTC

Investigating

We are currently investigating the issue surrounding 2 Factor Authentication in the European region.
Posted Mar 31, 2025 - 08:06 UTC
This incident affected: Qualtrics Social Connect (Web Interface).