EX Person Import Delays in European Region

Incident Report for Qualtrics

Resolved

This issue has been resolved.
Posted Apr 24, 2026 - 20:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2026 - 19:52 UTC

Investigating

We are currently investigating a delay with importing EX Persons in the European region.
Posted Apr 24, 2026 - 19:30 UTC
This incident affected: Administration.