EX Directory issues in the Canadian region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Mar 20, 2025 - 00:59 UTC

Investigating

We are currently investigating an issue with contact imports and searches in the EX Directory in the Canadian region.
Posted Mar 20, 2025 - 00:53 UTC
This incident affected: XM Directory & Contacts (XM Directory Automations, XM Directory Imports).