Survey export issues in multiple regions

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 11:33 UTC

Investigating

We are currently investigating an issue with exporting surveys in multiple regions.
Posted Jul 16, 2025 - 10:47 UTC
This incident affected: Surveys (Survey Editing).